Hyundai Genesis Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
I've tried searching all through the forum in order to find some information on this issue, but everyone seems to describe it differently and offer different solutions. So this is my first post on here trying to figure out where to start.

First off, about my car. This is basically everything done to the engine, since it may be relevant.
  • Injen SP intake
  • hks ssqv Bov
  • isr 02housing
  • tsudo downpipe
  • isr catback street
  • competition clutch stage 2
I have an ECU with the BTR stage 2 tune, and a stock ecu. I also have stock spark plugs, and one step colder spark plugs.

Now, onto the issue(s) its self

1.) Rough Idle
  • here is a video of an unusually rough idle.
  • The video above was an extreme example from a cold start, usually it just bounces a little bit, but as you can see that time the car was about to die due to how low the rpms dropped.
  • This issue does not happen all the time. Sometimes it idles just fine. It seems to be worse on cold start ups.
  • This happens with either plugs, with or without the tune,
2.) Jumpy Throttle
  • This issue is harder to describe and I don't have video footage of it.
  • This happens when driving at low throttle percent, regardless of rpm and gear, but it is more noticeable in lower gears due the tourqe.
  • When driving at low to medium throttle, like cruising on a road going 45 in 4th gear, or going through a drive thru or parking lot, the throttle position jumps up and down even though my foot isn't moving the pedal.
  • I have a tablet installed on my dash running torque. I have a graph showing time and throttle position and its very obvious by feeling the car and looking at the graph. After I pass the lower/mid throttle range, it is smooth as normal. At first it felt like a dead spot in the pedal, because I was either slowing down or speeding up, but after seeing the graph I realize that its the throttle "jumping" up and down.
  • This also happens with either ECU and either spark plugs
3.) Going into limp mode and giving throttle position code.
  • Seemingly randomly when I'm driving the car will go into limp mode. I can feel the jumpy-ness and rough idle worse than usual, and then a few minutes later when I'm driving the car will go into limp mode.
  • I won't build boost, and it keeps my rpms really low. I have to pull over, turn the car off and back on, then it goes back to normal. Well, besides the aforementioned issues.
  • When this happens, my check engine light comes on and I get a throttle position sensor code.
  • once again, all combinations of ecu and plugs doesn't yield any results
If you've read this far, thank you. I'm just trying to be as descriptive as possible in case anyone has a similar issue. This is the part that I find confusing, it doesn't always do it. Sometimes it runs fine, idles perfect and has great throttle positioning. It's hard for me to figure what would make it be great sometimes, but most of the time it jumps around all over the place.

Please let me know if you have any suggestions. I have a new throttle body on the way and hopefully that helps me out. Thanks in advance.
 

·
Premium Member
Joined
·
15,277 Posts
I've tried searching all through the forum in order to find some information on this issue, but everyone seems to describe it differently and offer different solutions. So this is my first post on here trying to figure out where to start.

First off, about my car. This is basically everything done to the engine, since it may be relevant.
  • Injen SP intake
  • hks ssqv Bov
  • isr 02housing
  • tsudo downpipe
  • isr catback street
  • competition clutch stage 2
I have an ECU with the BTR stage 2 tune, and a stock ecu. I also have stock spark plugs, and one step colder spark plugs.

Now, onto the issue(s) its self

1.) Rough Idle
  • here is a video of an unusually rough idle.
  • The video above was an extreme example from a cold start, usually it just bounces a little bit, but as you can see that time the car was about to die due to how low the rpms dropped.
  • This issue does not happen all the time. Sometimes it idles just fine. It seems to be worse on cold start ups.
  • This happens with either plugs, with or without the tune,
2.) Jumpy Throttle
  • This issue is harder to describe and I don't have video footage of it.
  • This happens when driving at low throttle percent, regardless of rpm and gear, but it is more noticeable in lower gears due the tourqe.
  • When driving at low to medium throttle, like cruising on a road going 45 in 4th gear, or going through a drive thru or parking lot, the throttle position jumps up and down even though my foot isn't moving the pedal.
  • I have a tablet installed on my dash running torque. I have a graph showing time and throttle position and its very obvious by feeling the car and looking at the graph. After I pass the lower/mid throttle range, it is smooth as normal. At first it felt like a dead spot in the pedal, because I was either slowing down or speeding up, but after seeing the graph I realize that its the throttle "jumping" up and down.
  • This also happens with either ECU and either spark plugs
3.) Going into limp mode and giving throttle position code.
  • Seemingly randomly when I'm driving the car will go into limp mode. I can feel the jumpy-ness and rough idle worse than usual, and then a few minutes later when I'm driving the car will go into limp mode.
  • I won't build boost, and it keeps my rpms really low. I have to pull over, turn the car off and back on, then it goes back to normal. Well, besides the aforementioned issues.
  • When this happens, my check engine light comes on and I get a throttle position sensor code.
  • once again, all combinations of ecu and plugs doesn't yield any results
If you've read this far, thank you. I'm just trying to be as descriptive as possible in case anyone has a similar issue. This is the part that I find confusing, it doesn't always do it. Sometimes it runs fine, idles perfect and has great throttle positioning. It's hard for me to figure what would make it be great sometimes, but most of the time it jumps around all over the place.

Please let me know if you have any suggestions. I have a new throttle body on the way and hopefully that helps me out. Thanks in advance.
What part was installed when this started happening?

Have you tried disconnecting the battery for and hour to reset the ECU?
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
What part was installed when this started happening?

Have you tried disconnecting the battery for and hour to reset the ECU?
All parts were installed when it was running good. Its like it slowly got worse, or is getting worse. I've reset the ecu twice and it didnt fix the issues. Thank you for the suggestion though
 
1 - 3 of 3 Posts
Top