Hyundai Genesis Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
24 Posts
Discussion Starter · #1 ·
Has this happened to anyone else?

I was driving at 40mph in second gear for like two miles. (I know, not smart) .. The traction just turned off in the middle of driving and I didn't go anywhere near the button to turn it off.

After I realized that it turned off, I tried turning it back on by pressing the button with no success. I eventually had to restart the car to get it to come back on.

I've searched for this problem, but I haven't seen anything about it. Any ideas one why this happens?
 

·
Registered
Joined
·
478 Posts
Yeah, all I know is that our TC is pure crap. Had the rev hang fix, but it still interferes. I am about to say screw it and trade the car in.
 

·
Registered
Joined
·
33 Posts
I don't know about the problem, but what I know is that you could have shifted to 4-5th gear with that speed...+ saved on gas...40mph on second gear is about (5000 RPM) which makes the fluid and the 2nd gear really hot...but who cares, 10 years warranty :D
 

·
Registered
Joined
·
2,012 Posts
Yeah, all I know is that our TC is pure crap. Had the rev hang fix, but it still interferes. I am about to say screw it and trade the car in.
The traction control on these cars really holds the car back. It's awful when you're giving it full throttle and it's cutting throttle because it's sensing slipping. :mad:

The worst part is the A/T shifts near red line, even in sport mode, so when you're slightly spinning in first, as soon as you hit 6000 rpm it will shift into 2nd causing you to bog horribly.
 

·
Registered
Joined
·
2,795 Posts
A Tech at my local dealer told me that he had seen them completely removed by customers already. I mean it's just sensors and crap.

Also, turning off the TC after starting my car works fine for me. It doesn't interfere at all after that.
 
1 - 6 of 6 Posts
Top