Hyundai Genesis Forum banner
1 - 15 of 15 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter · #1 ·
I was wondering if any of you guys know what my problem is. So basically i’ve been having turbo flutter for a couple of weeks now and my turbo only goes up to 5 psi. I also the p2261 CEL a few times but it comes ans goes on its own. The only thing i have is an aftermarket cold air intake. I also replace the turbocharger wastegate solenoid but nothing changed! pls help
 

·
Member
Joined
·
179 Posts
Check your vacuum lines. Make sure they're not loose or ripped.
The one that goes from the bov selenoid to the bov became loose on mine. Similar issue, just no CEL on mine.
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #3 ·
I checked everything and it looks fine but i think it might be my stock recirulating valve that isn’t working properly! Im thinking about changing it for a blow off valve but i was wondering if it is dangerous/bad to change from a recirculating valve to a blow off valve
 

·
Member
Joined
·
179 Posts
I checked everything and it looks fine but i think it might be my stock recirulating valve that isn’t working properly! Im thinking about changing it for a blow off valve but i was wondering if it is dangerous/bad to change from a recirculating valve to a blow off valve
It's fine. That's how we all do it :)

The valve dumps the air back into the airbox long before it hits any sensor of any sort :)

IDK how to test the valve... Would hate for you to keep throwing money at it and the problem not going away.
 

·
Premium Member
Joined
·
16,436 Posts
View attachment 78569
is that what ur saying to replace? if so i already did.
Is this for a bk1 or bk2?

bk1 has 2 solenoids, one going the wastegate actuator and the other going to the bypass valve.
I said the BYPASS VALVE SOLENOID. they are basically the same, but the electrical connection is different.

bk2 ONLY has the solenoid for the bypass valve, since the wastegate is a ewga.

Another thing I would do is unbolt the bypass valve and inspect it for any internal damage, for some reason.
 

·
Premium Member
Joined
·
16,436 Posts
yea the one i changed is the one connected to the bpv but yea i think im going to inspect for internal damage thanks!
also, there is a check valve on top of the intake manifold. It's the green/white thing.
take a photo of it so you know which way it goes when you put it back.
check to see if it only allows flow in one direction. If it's fine, put it back.
Also, there is a small vacuum line that goes from the BOTTOM of the intake manifold to the solenoid, via metal line thats bolted to the front of the engine.
Make sure that's connected.

EDIT: also if you are using any vinyl hoses from the hardware store. Throw them away, shouldn't you them for anything automotive.
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #11 ·
I think i found the problem! i checked inside the bpv and when i push it down it gets stuck and doesn’t come back up by itself! I ordered a forge motorsport bov hopefully thats goind to fix it!
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #12 ·
After installing the forge motorsport blow of valve i get the same problem! The blow off valve is just not opening like the stock one. I’m probably going to send my car to a garage to find the issue.
 

·
Member
Joined
·
179 Posts
Are you in Canada? I assume...
If you're local to the DC area in the US, I'll be happy to take a look!


Take a picture of your connections to the blow off valve.
 
1 - 15 of 15 Posts
Top