Hyundai Genesis Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter · #1 ·
Hey guys. I just put my winter tires on my gen. and i have notices that when i accelterate kinda hard my traction control light flashes and i loose power(as if i was spinning tired with tc was on). I thought maybe cuse i actually was spinning tires so i tried flooring it in 5th gear doing about 100km/h and the same thing happened. Does anyone know whats wrong?
 

·
Registered
Joined
·
60 Posts
It sounds like you put a different size tire on than the OEM and the traction control thinks they are spinning. I'm guessing you went with narrower tires but kept the same sidewall ratio or you went with a square set-up?
 

·
Advenio Pariter
Joined
·
3,967 Posts
I use a square winter setup and my ECS goes wonky like that. When I replace my winter tires I will go to a staggered setup. Turn off the ECS and drive commando...
 

·
Registered
Joined
·
591 Posts
No problems running square winters , mine are 17 in. ( OEM 18in. for summer ) 225/50 front and 225/55 rear . Taller rear side wall gives the proper ratio. I drive with TC on most of the time in the winter .
 
  • Like
Reactions: TsukubaRed_PA

·
Registered
Joined
·
150 Posts
Hey guys. I just put my winter tires on my gen. and i have notices that when i accelterate kinda hard my traction control light flashes and i loose power(as if i was spinning tired with tc was on). I thought maybe cuse i actually was spinning tires so i tried flooring it in 5th gear doing about 100km/h and the same thing happened. Does anyone know whats wrong?
What are your tire sizes (front tires and rear tires)?
 
1 - 8 of 8 Posts
Top