Hyundai Genesis Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hello good day, a few days ago I acquired a wotbox used by a friend. I have a hyundai genesis 2.0t 2013 of 275cv install it and I have a problem the launch control only works at 2500 rpm. I program it for 3000 or 4000 rpm and it does not work directly or it continues doing it at 2500rpm. any solution to this problem? From already thank you very much !
 

·
Registered
Joined
·
1,000 Posts
I had the same issue and I haven't had time to dig into it. For me, when I wired it up the way the instructions say I can't get launch control or rev limiter to work.

I just use my wotbox for no lift shifting for now.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
I had the same issue and I haven't had time to dig into it. For me, when I wired it up the way the instructions say I can't get launch control or rev limiter to work.

I just use my wotbox for no lift shifting for now.
I found the solution to the problem, I had done it as well as the instructions and the videos about the installation, after searching and researching I ended up finding the electric planes of the bk2 2.0 and I found that the rpm reader for the cable Yellow of the wotbox is on the first cylinder, bone on the side of the grill. The yellow wire of the Wotbox goes to the brown wire of the first cylinder. with that the problem was solved and now the step launch works perfectly.


I hope I can solve the problem too.

What configuration do you have for the no lift shifting?
 
1 - 4 of 4 Posts
Top