Name That Noise ? - Hyundai Genesis Forum
 
LinkBack Thread Tools Rate Thread
post #1 of 1 Old 2 Weeks Ago Thread Starter
Junior Member
 
Join Date: Jun 2019
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Name That Noise ?

I’m a new member here.. my ‘13 gen Coupe 2.0T is making a weird noise. It’s been less than 90 days since I replaced the wastegate actuator ($700) & after that I got into a wreck and had to repair just the body / suspension(just got it back a week ago). With the wastegate I had an engine light but now no engine light. The car is making a grinding noise every time I accelerate. Not getting any psi from the boost. It stops at 0. How do I attach a video? I have a video of the noise I’m getting.
nwarrick97 is offline  
Sponsored Links
Advertisement
 
Reply


Tags
None

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Hyundai Genesis Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Rate This Thread
Rate This Thread:



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome